Opened 5 years ago

Last modified 3 years ago

#9143 new Support Requests

boost can not load bootstrap

Reported by: m_hartley4@… Owned by:
Milestone: To Be Determined Component: Building Boost
Version: Boost 1.54.0 Severity: Showstopper
Keywords: Cc:

Description

when i try to load bootstrap.bat i get this error

cl.exe System Error

The program can't start because mspdb110.dll is missing from your computer try reinstalling the program (which I did) to fix this probelm

Change History (7)

comment:1 Changed 5 years ago by Steven Watanabe

Can you compile anything with cl?

comment:2 Changed 4 years ago by anonymous

I get the same error. I can build other programs, even from the command line. This issue occurred with Boost version 1.56.0 for me. Visual Studio 2013 full install was successfully performed.

comment:3 Changed 4 years ago by anonymous

Same issue here.

comment:4 Changed 4 years ago by anonymous

I have same issue.

comment:5 Changed 4 years ago by anonymous

boost 1.57.0, the same. no solution and no suggestions even?

comment:6 Changed 4 years ago by Steven Watanabe

It sounds like it's not finding vcvarsall.bat. Have you tried running bootstrap from a VS command prompt? From the source, I think it's looking for %VS120COMNTOOLS%..\..\VC\VCVARSALL.bat. Can you check your environmental variables and that path?

comment:7 Changed 3 years ago by charles

I was getting the same error and I noticed that when I opened up a VS command prompt I got the error "ERROR: Cannot determine the location of the VS Common Tools folder." I fixed that problem by adding "c:\Windows\System32" to my PATH environment variable and now I don't get either error and can build Boost.

Note: See TracTickets for help on using tickets.