Modify

Opened 4 years ago

Closed 3 years ago

#9273 closed Bugs (fixed)

error: ‘::SSL_CTX_clear_options’ has not been declared

Reported by: Blake McBride <blake@…> Owned by: chris_kohlhoff
Milestone: To Be Determined Component: asio
Version: Boost 1.54.0 Severity: Problem
Keywords: Cc:

Description

Greetings,

I built and installed boost 1.54.0 on a Mac OS/X 10.6.8 utilizing GCC 4.2.1. I did:

sudo ./b2 install

It proceeded for a long time and ended with:

...
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/link-static/threading-multi/cpplexer/re2clex/aq.o
darwin.compile.c++ bin.v2/libs/wave/build/darwin-4.2.1/release/link-static/threading-multi/cpplexer/re2clex/cpp_re.o
darwin.archive bin.v2/libs/wave/build/darwin-4.2.1/release/link-static/threading-multi/libboost_wave.a
common.copy /usr/local/lib/libboost_wave.a
...failed updating 6 targets...
...skipped 4 targets...
...updated 1016 targets...
Blake-Mac-17:boost_1_54_0 blake$ 

I presume the build was successful. Now, when I try to build an app that uses it, I get:

In file included from /usr/local/include/boost/asio/ssl/context.hpp:786,
                 from /usr/local/include/boost/asio/ssl.hpp:19,
                 from /Users/blake/Backup/wt-3.3.1/src/Wt/Http/Client.C:25:
/usr/local/include/boost/asio/ssl/impl/context.ipp: In member function ‘boost::system::error_code boost::asio::ssl::context::clear_options(long int, boost::system::error_code&)’:
/usr/local/include/boost/asio/ssl/impl/context.ipp:249: error: ‘::SSL_CTX_clear_options’ has not been declared
make[2]: *** [src/CMakeFiles/wt.dir/Wt/Http/Client.o] Error 1
make[1]: *** [src/CMakeFiles/wt.dir/all] Error 2
make: *** [all] Error 2

It seems to me the problem is in boost. Any help would sure be appreciated.

Thanks.

Blake McBride?

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by viboes

  • Component changed from None to context
  • Owner set to olli

comment:2 Changed 4 years ago by olli

  • Owner changed from olli to chris_kohlhoff

seems to be a problem of boost.asio (SSL) and not boost.context

comment:3 Changed 4 years ago by olli

  • Component changed from context to asio

comment:4 Changed 3 years ago by marco.serantoni@…

Is resolved in development repository, SSL_CTX_clear_options was not present in the previous releases of OpenSSL and this condition is now handled.

comment:5 Changed 3 years ago by chris_kohlhoff

  • Resolution set to fixed
  • Status changed from new to closed

Was fixed in r86463 and included in boost 1.55.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain chris_kohlhoff.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.