Opened 9 years ago

Closed 4 weeks ago

Last modified 17 hours ago

#2979 closed Bugs (duplicate)

boost::gil::image_is_basic does not match description

Reported by: carlos.rocha@… Owned by: Mateusz Loskot
Milestone: Boost 1.69 Component: gil USE GITHUB
Version: Boost 1.38.0 Severity: Problem
Keywords: image_is_basic gil Cc: mateusz@…, Mateusz Loskot

Description

The description of the metafunction boost::gil::image_is_basic says that it will return mpl::true_ if the image uses a basic view and std::allocator<unsigned char>, however the implementation returns true for any kind images that use any kind of allocator.

Change History (7)

comment:1 Changed 9 years ago by anonymous

Keywords: gil added

comment:2 Changed 20 months ago by Mateusz Loskot

Cc: mateusz@… added

comment:3 Changed 15 months ago by Stefan Seefeld

Owner: changed from Hailin Jin to Stefan Seefeld

comment:4 Changed 3 months ago by Mateusz Loskot

Cc: Mateusz Loskot added

comment:5 Changed 5 weeks ago by Mateusz Loskot

Milestone: Boost 1.39.0Boost 1.69
Owner: changed from Stefan Seefeld to Mateusz Loskot

Fixed by pending pull request https://github.com/boostorg/gil/pull/128

comment:6 Changed 4 weeks ago by Mateusz Loskot

Resolution: duplicate
Status: newclosed

Closing as duplicate of the PR at ​https://github.com/boostorg/gil/pull/128

comment:7 Changed 17 hours ago by Mateusz Loskot

Note: See TracTickets for help on using tickets.