Opened 6 years ago

Closed 8 weeks ago

Last modified 8 weeks ago

#7092 closed Bugs (duplicate)

Fix odd workarounds for function object in for_each_pixel

Reported by: Nana Sakisaka <n.sakisaka@…> Owned by: Stefan Seefeld
Milestone: Boost 1.69 Component: gil USE GITHUB
Version: Boost Development Trunk Severity: Regression
Keywords: Cc: mateusz@…

Description

Current implementation for for_each_pixel is somehow re-assigning the functor to its own variable.

This becomes a serious problem when using a C++11 lambda-expression for the functor.

Since the copy assignment operator for lambda-expressions is declared deleted by the standards, this makes it unable to pass lambda-expression for the functor of for_each_pixel. Obviously this is a serious problem for writing C++11 style codes.

See attached patch for suggested workaround.

Attachments (1)

patch (472 bytes) - added by Nana Sakisaka <n.sakisaka@…> 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Nana Sakisaka <n.sakisaka@…>

Attachment: patch added

comment:1 Changed 21 months ago by Mateusz Loskot

Cc: mateusz@… added

comment:2 Changed 17 months ago by Stefan Seefeld

Owner: changed from Hailin Jin to Stefan Seefeld

comment:3 Changed 8 weeks ago by Mateusz Loskot

Resolution: duplicate
Status: newclosed

Fix submitted via GitHub? https://github.com/boostorg/gil/pull/139 pending review

comment:4 Changed 8 weeks ago by Mateusz Loskot

Milestone: To Be DeterminedBoost 1.69

FYI, the PR with fix has been accepted. Thanks!

Note: See TracTickets for help on using tickets.